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DRAFTING
---------------------------------------------------------------------------------------------------------------------

Beginning Drawing
---------------------------------------------------------------------------------------------------------------------

View Only Mode
File  -->  Open;  Click Retrieve Drawing as View Only icon (upper right )
In View Only mode, the system doesn't retrieve any associated models
Drawing can not be modified
If you wish to modify the drawing, use File --> Retrieve Models

Mark-up Mode File  -->  New  -> Markup

Disallow Changes Affecting 3D Model from drafting
draw_models_read_only  yes

New Drawing with Honeywell Format
Intralink  -->  Library  -->  Forms  -->  ap-1302-2007....

Adding Models to the Drawing
File  -->  Properties

(File Properties), Dwg Models  -->  Add Model

Change Model:  Dwg Models  -->  Set Model  or Set Model Icon drop down list
Highlight current active model:  File --> Properties --> Dwg Models --> Model Disp --> Hilite Curr
Return to Normal Display:  Model Disp --> Normal

Reorder Sheets Edit  -->  Move Sheet

Move Items to Another Sheet Edit  -->  Move Item to Sheet

Drawing Options
File  ->  Properties  ->  Drawing Options

Drawing Format Fractional Scale
view_scale_denomitor  1 (from 0)
view_scale_format   fractional

drawing_text_height  .15
draw_arrow_style    filled
model_display_for_new_views no_hidden
tan_edge_display_for_new_views no_disp_tan
axis_line_offset .05
circle_axis_offset .05
witness_line_offset .1

min_balloon_radius .25
max_balloon_radius .25
gtol_datums std_asme
detail_circle_line_style phantomfont
crossec_arrow_length .32
crossec_arrow_width .12
dim_fraction_format std

tol_display no,  Yes adds tol to EVERY DIMENSION!!!!!!!!

Config.pro
pro_format_dir folder name for format symbols

To load a drawing options config config.pro,  drawing_setup_file [browse]



Create Drawing TIFF
current screen: File  -->  Save a Copy;  new name;  Type = Tiff
whole sheet File  -->  Print;   Destination -->  Add Printer Type  -->  TIFF or JPG

Drawing Views
---------------------------------------------------------------------------------------------------------------------
Insert a General View

A general view is usually the first view placed on a sheet. It's the most versatile view - it can be scaled or rotated. 
Click Insert > Drawing View > General.  

Select a location on the screen to place the general view. The general view appears and the Drawing View dialog 
box opens. By default, the View Type category is selected and the options for defining the view type and 
orientation display.  

Under View Type, you can modify the view name, however, if a general view has not yet been displayed, you can 
not change the view type.

Position the general view on drawing by selecting an orientation method and defining orientation requirements:
View names from the model—Orient using saved views from the model. 
Select the appropriate model view from the Model view names list. 

Define the x and y orientation by selecting the desired Default orientation. You can select either Isometric, Trimetric, or 
User Defined; in which case you type in custom angle values. 

Geometry references—Orient using geometry references from the previewed model in the drawing.

Select the direction to orient the reference from the list next to the reference being defined. The list provides several 
options, including Front, Back, Top, and Bottom. 

Select the desired reference on the model previewed on the drawing. The model repositions according to the direction 
defined and the references selected. 

You can change the orientation by selecting another direction option from the direction list, and you can change the 
selected reference by clicking the reference collector and selecting a new reference on the drawing model. 

Note: To return the view to its original orientation, click Default Orientation. 

Insert a Projection View
Click Insert > Drawing View > Projection.   
Select parent view that you wish to display in the projection. 

A box appears over the parent view, representing the projection. 
Drag box to desired location. 
Left-click to place the view. 

To modify the properties of the projection, select and right-click the projection view. 
Click Properties on the shortcut menu. 

Ok

Insert a Detailed View
Click Insert > Drawing View > Detailed. The Select dialog box opens. 
Select the point on an existing drawing view that you want to enlarge in a detailed view. 
The drawing item highlights and you are prompted to sketch a spline around the desired point. 

Insert an Auxiliary View
Click Insert > Drawing View > Auxiliary. The Select dialog box opens.  
Select an edge, axis, datum plane, or surface to create the auxiliary view from. 
A box appears over the parent view, representing the auxiliary view.  
Drag the box horizontally or vertically to the desired location. 
Left-click to place the view.

Insert a Revolved View
Click Insert > Drawing View > Revolved. 

Insert a 'Copy and Align' View
Click Insert > Drawing Views > Copy and Align. 
You are prompted to select an existing partial view.....



Switch Views to Another Sheet
Select the view to move to another sheet.
Click Edit > Move Item to Sheet. You are prompted for a target sheet number. 

Delete a View
Select the view to delete. The view highlights.
Right-click and click Delete from the shortcut menu or click Edit > Delete

Dimensioning
---------------------------------------------------------------------------------------------------------------------

Over-ride default dimension values
&D - current dimension
@O - hides dimension value and type new dimension as text
&S - shows dimension name (or is it @S?)

Update after Modifying Drawing Options
View  -->  Repaint or select the Redraw button
View  -->  Update  -->  Current Sheet or All Sheets
Info --> Check Display Status

Dimension Decimal Places
Format  ->  Decimal Places   [3]

Trailing Zeros
File  ->  Properties  ->  Drawing Options 
change drawing properties under file menu. Option "lead_trail_zeros" should be set to "both". 

Clip Dimension Witness Line
Insert  -->  Break
(Restore with RMB  -->  Remove All Breaks)

Relate (Group) Text to Dimension
Select objects to add to dimension;   Edit -> Group -> Relate to Object

Add Leader Line to Object
Select object; RMB -> Edit Attachment;  

Mod Options -> Add Ref
Ctrl key allows multiple points

Move Leader in Multi Line Text
@o (letter oh) at the beginning of the line of text

Multiple leader lines
<CTRL> Keep selecting....
Pick Free point if you want the point in space

Thread Note - Edit Highlight Note --> RMB  -->  Edit Value
In 3D Model, select annotation, RMD --> Properties

Dual Dimensioning
File  ->  Properties  ->  Drawing Options

dual_dimensioning drawing setup file option
modify the dimension properties by right-clicking the selected dimension and click Properties 

Draft Scale draft_scale

Dimension Symbols  (Info  -->  Switch Dimensions)
d     = driving - created in 3D model and bidirectonally associative
ad   = driven - drawing created dims related to model features and can't be modified.  stored with model
add = drafting created and related to the model but stored with drawing only.  (config.pro change reqd)
dd   = drafting dimension not associated to entities.  (setup file associative_dim = no)

Special Characters
plus/minus = [Alt] 241



text in a box:  @[ text in a box @]
super script  [@+text@#] subscript [@-text@#]
to get an @ symbol or & symbol in nore text, you must type them twice...  "SEE VIEWS 1 && 2"

see the Pro/ENGINEER Installation and Administration Guide

Save Drawing Notes select text to save;    Info  -->  Save Note     enter file name to save as .txt

Datum Flag Insert  -->  Draft Datum  -->  Plane,  (2 digitize points on edge)
Style set my drawing option: gtol_datums

Create Ordinate Dimensions
Before you can create an ordinate dimension you must have a standard linear dimension defined on the baseline 
reference you want to use. You then convert the linear dimension to an ordinate dimension, defining one of one of the 
linear dimension's witness lines as the ordinate baseline in the process. 

Select the standard dimension to convert to an ordinate dimension. 
Right-click and select Toggle Ordinate/Linear. from the shortcut menu. 

You are prompted to select the witness line to be the baseline.

Select the witness line to be the baseline. 
The ordinate dimension is created, and the other witness line is dimensioned from the base.

Click Insert  > Dimension > Ordinate. You are prompted to select the baseline. 
Click the zero value on the baseline to select it.

Select the next edges to dimension. 

Middle-click at the required location to place the ordinate dimensions.

Create Ordinate Dimensions Automatically
Insert > Dimension > Auto Ordinate. You are prompted to select one or more surfaces.
Select one or more surfaces for which you want to create ordinate dimensions. The AUTO ORDINATE menu appears. 

Note: You must select surfaces belonging to the same view of the drawing.
Click Select Base Line.
In the same view from which you selected the surface or surfaces, select a reference line (edge, curve, or datum plane) to 
create the ordinate dimensions.

Saving Dimensions to the Part or Drawing
When you create dimensions in Drawing mode, the configuration file option create_drawing_dims_only determines 
whether the system saves them in the associated part or in the drawing itself. 

When set to no, (the default), it saves all new model dimensions (not draft dimensions) created in the drawing to the 
associated part or assembly. Draft dimensions are still saved to the drawing.

When set to yes, it saves all new dimensions created in the drawing in the drawing only.

Display 
---------------------------------------------------------------------------------------------------------------------

Working in Multiple windows
Window -->  New

You can open the same drawing but a different area or other sheet.

Display Cosmetic Features
hlr_for_threads   or  View -> Show&Erase;  Cosmetic Feature

Axis Display
Show/Erase Dialog Box:  Type    [_ _ _ A_1]   Show, Erased, Never Shown, etc
Axis Names:  View  -->  Display Settings  -->  Datum Display
Insert  -->  Draft Datum  -->  Axis:    Edit  -->  Transform: Rotate, Translate
Create a break in an Axis:  Insert  -->  Break
Axis Symmetry Line:  Insert  -->  Symmetry Line Axis



Rotate:   Edit  -->  Attachment

Absolute Coordinates
draw_points_in_model_units
With line or shape command, RMB -> Absolute Coords -> input box opens

Grid
View -> Drawing Display -> Model Grid;  dialog box displayed
View -> Show Grid

View -> Draft Grid;   grid modify menu appears
Grid Modify -> Origin

Info -> Draft Grid

Printing - Pen Table
file name = table.pnt

!Exclamation points denote comment lines in the file
!
!Change yellow entities to plot w/ pen 1
pen 1 thickness 0.1 cm; letter_color
!
Change hidden lines to plot w/ pen 2
pen 2 pattern 0.1, 0.1 in; thickness 0.1 cm; half_tone_color
!change geometry lines to pen 3
pen 3 drawing_color
!
Green sheetmetal lines to pen 5
pen 5 thickness 0.1 in; attention_color

Hidden Lines in PDF
set the Style to Geometry and the Line Font to PDFHIDDEN_STYLE. 
The line will be white in color.

Highlight Items by Type
Edit  -->  Highlight by Attributes

Dimension Type:
Owned by Model - created and associated in 3D model
Created and Assoc - drawing created dimensions and related to model for updates
Created non-Assoc - drawing created but will not update with model

Running Drawing Programs
Tools  -->  Drawing Program

Drawing Parameters
Tools -> Parameters
See SYSTEM PARAMETERS FOR DRAWINGS in the help files

Including Parameter Information in Notes
When you set the drawing set up file option yes_no_parameter_display to yes_no, parameters can have a yes or no value in 
drawing notes. When you set it to true_false (the default value), they can have a true or false value.

To specify parameter information in a note, use the following format:
Dimensions—&d# or &ad#, where # is the dimension ID. Examples: &d12. &ad5. 
Reference dimensions—&rd#, where # is the dimension ID. Example: &rd2.
Instance number—&p#, where # is the parameter ID. Example: &p8
User-defined parameters—&xxxx where xxxx is a symbol defined in a relation.
Datum names—&dtm_name, where name is the name of a datum plane.
Drawing labels—You can add the following drawing labels to a drawing:

&todays_date—Adds the date as of the note’s creation in the form dd-mm-yy (for example, 2-Jan-92).   If you 
include this symbol in a format table, the system evaluates it when it copies the format into the drawing.

&model_name—Adds the model used for the drawing.
&dwg_name—Adds the name of the drawing.
&scale—Adds the scale of the drawing.
&type—Adds the drawing model type.



&format—Adds the format size.
&linear_tol_0_0 through &linear_tol_0_000000—Adds the linear tolerance values for one to six decimal places.
&angular_tol_0_0 through &angular_tol_0_000000—Adds the angular tolerance values for one to six decimal 

places.
&current_sheet—Adds the sheet number for the sheet on which the note is located.
&total_sheets—Adds the total number of sheets for the drawing.
&pdmdb - product database of origin
&pdmrl - model release level
&pdmrev-model revision
&pdmrev:d - drawing revision

Drawing parameters—&parameter:d, where parameter is the parameter name.

Text
---------------------------------------------------------------------------------------------------------------------
Different Fonts within the same piece of text

You can easily change text parameters by using curly brackets to break up a text string.
Example:  This is a single string of text with some}{1:BOLD TEXT} embedded within it
Next use the Format  -->  Text Style command to select the section of text to change.

Super Script/Sub script
SuperScript by adding @+ and close with @#
SubScript uses @- and closes with @#
(Add a blank superscript to the end of each line in a paragraph if you want to keep same line spacing.)

Add a Symbol in Text String
&sym(sym_name)  no symbol extension is needed

Adding part names within text
&dwg_name
&model_name

Adding Drafting Entities
---------------------------------------------------------------------------------------------------------------------

Relating Entities to a view
When adding drafting entities, they are not related to the view.  If the view moves...
Select entities, Edit --> Group --> Relate to View, select the view to relate to.
(If an ent is dimensioned to a view, it becomes related)

Changing Line Font
Format --> Line Style --> Modify Lines

Drafting Tables
---------------------------------------------------------------------------------------------------------------------

Merge cells into a large block
Table --> Merge Cells --> Rows

Insert a Row or Column
Table > Insert > Row or Column.

To insert a row, select a horizontal line in the table. 
A new row is placed between the two rows that border the selected line. 

To insert a column, select a vertical line in the table. 
A new column is placed between the two columns that border the selected line.

Remove a Row or Column  
Click a cell in the column or row you want to remove.
Click  Table > Select > Row or Column. The row or column is selected.

Press Del. The column or row is deleted. 
(You can use Undelete on the right mouse button shortcut menu to abort the deletion, 
or click open space on the drawing to confirm it.)

Merge Cells
Ctrl key-select cells to merge. 
Select the opposite corners of a range of cells to merge across rows and columns.



Click Table > Merge Cells

Unmerge - Table > Unmerge cells

Change the Table Origin
Select the table.  
Click Table > Set Rotation Origin. All the corners of the Table highlight.
Pick one corner to be the new origin

Blank or Display Cell Borders (Lines)
Select the entire table.
Click Table > Line Display. 

Blank—Blanks the selected line segment.
Unblank—Redisplays the selected line segment in the table.
Unblank All—Redisplays all blanked lines in the table. 

Resize Rows and Columns
Select the rows or columns to reset.
Click Table > Height and Width. 
Use the dialog box to set the new dimensions for the selected rows or columns.

Move a Table
Click to select the table. 
Move the cursor over one of the handles on the outline, until the cursor changes to a four-way arrow.
Hold the left mouse button down, and drag the table to where you want it.
Release the left mouse button to place the table.
Alternately, you can use Edit > Move Special to enter X and Y coordinates for the target location.
Note: To move a table to another sheet, select the table and use Edit > Move Item to Sheet.

Save a Table
Select the table or a cell of a table to save.
Click Table > Save Table > As Table File or As Text File
Type a name for the table. Saves to a file in current directory with .tbl extension.  .txt extension for test file.

Retrieve a Saved Table
Click Table >  Insert > Table from File.
Select the name of the saved .tbl file in the file browser. 
Table outline appears with upper-left corner attached to the pointer

Balloons
---------------------------------------------------------------------------------------------------------------------
Control BOM Balloon Size
BOM balloon size is controlled by text size. 

To make a selected balloon or balloons larger or smaller, 
Click Text Style from the right mouse button shortcut menu.
Text Style dialog box opens. 

Use the Height field to enter a height for the text.
Click Apply or OK to finish.

If you want to apply a range limit to BOM Balloon size, use the detail setup options (File > Properties > Drawing Options) 
min_balloon_radius
max_balloon_radius
Set a numeric value for each. Values apply to all newly created balloons. 
If you set a value of zero there is no min. or max. radius.

Show BOM Balloons in an Assembly View
To show BOM balloons in an assembly view, there must be a table in the drawing with a repeat region containing at least 
the report symbol for the report index number (rpt.index) and the model name (asm.mbr.name).  Additionally, the repeat 
region must be set as a BOM balloon region. 

Select the target component in the model tree or in the drawing.
RMB menu to select Create BOM Balloons. Select the view. 
For quantity balloons, you may be prompted to enter number how many of total quantity you want balloon to represent.

Note: If a balloon is shown for a component, you can use the right mouse button shortcut menu to add a reference 
balloon for other instances of the component.



Alternately, you an use one of the methods in the menu manager-
Click Table > BOM Balloons. The BOM Balloon menu opens on the Menu Manager. 
Click Create Balloons. 
Click a BOM balloon region in a table. The BOM View menu opens on the Menu Manager.
Click one of the following:

Show All - Show all balloons associated with the table region. 
They may be spread across several views depending on the views orientations.

Note: If you have shown a balloon for every row in a repeat region, you can add additional balloons for every 
instance of the component in the model by selecting Show All again. You are prompted to add additional balloons 
for each assembly component. 

By View - If a region refers to more than one view, select which view to show balloons. 
By Comp - Select a specific component or components for which to show balloons.
Comp & View - If a region refers to more than one view, select which view to show balloons. 

Clean the BOM Balloon Layout - To automatically clean the BOM balloon layout: 
Select BOM balloons or a view having BOM balloons.
Click Edit > Cleanup > BOM balloons. The Clean BOM Balloons dialog box opens.

Use the dialog box to automatically set the position and spacing of a set of BOM balloons. You can set an offset 
from the view outline, guide by existing snap lines, and-or set up a stagger increment value. You can determine 
whether the leaders will point to edges or surfaces.  

To preview the results, click Apply. To accept them, click OK.

These detail setup options control the default settings for the Clean BOM Balloons dialog box:
def_bom_balloons_view_offset offset distance between ballons and view boundary

 def_bom_balloons_stagger specifies whether balloons are shown staggered by default
 def_bom_balloons_stagger_value distance between consecutive offset lines in staggered is Yes
 def_bom_balloons_snap_lines determines if snap lines are created around the view
 min_dist_between_bom_balloons minimum distance between bom balloons
 def_bom_balloons_attachment the default attachment method
 
Change the Balloon Leader Attachment Point and Style

Select the balloon to change.
RMB, click Edit Attachment.

Use the menu to apply an attachment location and a leader style to the balloon. 
For example, to change an arrowhead pointing to an edge to a clear dot attached to a surface, 

Highlight On Surface and Dot in the menu
Click the surface to which you want to attach the dot. 
Done

Add Reference BOM Balloons
You can create additional reference BOM balloons for each component in different views. The REF designation appears as 
shown below for simple and quantity or custom balloons. Reference BOM balloons are only available for components that already 
show BOM balloons. 

Set the drawing filter to "component."
Click the part to which to add the balloon. (You can also select from the model tree.) 
From the right mouse button shortcut menu, click Add Reference Balloon. The reference balloon is added to  the part. 

Note: The text for the REF balloon is set by the drawing setup option reference_bom_balloon_text

Custom Symbols
Click Table > BOM Balloons. The menu manager opens. 
Click BOM BALLOONS > Alt Symbol
Select quantity or custom balloons of the selected repeat region, then click OK. 

From the GET SYMBOL menu, select a user-defined symbol. Any selected balloons change to match the selected 
symbol, and the system redisplays the new balloons using the selected symbol for any selected components. 

For regions that use a user-defined symbol to display balloons, choose GET SYMBOL > Reg Default. The selected 
balloons revert to the default symbol of the region, and the system shows new balloons for the selected components 
using that symbol.

Tip: Setting the Default Arrow Style for BOM Balloons
setup file options

def_bom_balloons_edge_att_sym
def_bom_balloons_surf_att_sym


