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Modeling 3D
---------------------------------------------------------------------------------------------------------------------

▼ →■  □  █

Customizing Menus
Tools  -->  Customize Screen

Drag menu buttons to where you'd like them to reside.
example:  Erase Not Displayed

Display Datums while re-orienting model:
View   ->   Display Settings   ->   Model settings

Display while reorienting
[X] Datums

{config.pro setting:  spin_with_part_entities = yes}

Performance:
Frame rates
Hidden Lines
Detail Levels

Save Current Color Scheme
View  -->  Display Settings  -->  System Colors

File  -->  Save    (File name.scl)
(system_colors_file)

View Model Creation History
Tools  -->  Model Player

Turn Off Threaded Hole Text Tags
Tools  ->  Environment
3D Notes (Remove Check Box)
OK

?  Settings -> Tree Filter -> Check: Features & Annotations -> Expand tagged part -> Turn off Notes in expanded feature

Edit Threaded Hole Text Tags
Selector = Annotation, Select note, RMB -->  Properties
Can also edit in Drawing

Turn Off Threaded Hole Cosmetics using Layers
Create a new LAYER

Name: COSMETIC_THREAD
Rules -> Options -> Independant

Options -> Associative
Edit Rules -> 

■ Type
Comparison: is equal to
Category: All
Value: Hole

Turn Off ECAD Cosmetics using Layers
Create a new LAYER

Name: COSMETIC_PWB
Rules -> Options -> Independant

Options -> Associative
Edit Rules -> 

■ Type
Comparison: is equal to
Category: All
Value: Cosmetic



Save Layer Status
Layer tree:  RMB,  Save Status

Align a hole in an assembly with no relations:
Activate Part in the assembly to receive the hole
Insert Hole

Placement (tab bottom left)
Select primary Surface
Secondary References

Select Center Line of reference part
Change Offset to Align (both places)

Dimension Orientation Reference
Select any surface
(hole should now be aligned to CL of reference part)

Secondary References
Remove (references to CL)
Attach secondary references to datums or edges as desired

Set hole Diameter
Set hole Depth

Copy Hole
Insert Hole

Place as desired
Select Hole

Edit  -->  Copy
Edit  -->  Plaste Special

[ X ] Make coiped dependant on dim of originals
[OK]

Select primary Surface
Secondary References

Pattern Using Relations
Variables can be defined with numbers or formulas using Tools --> Relations
Within the pattern control panel, the DIMENSIONS pull up - 

select the Increment dimmension number and check box: Define increment by relation
Complete the pattern

Highlight the pattern feature on the part to show the pattern dimensions and locate the X HOLES dimension
The curser popup will display a P-number.  Add this number to the relations table 

(for example: P208 = 6 or P208 = number_of_holes)
regenerate and pattern should now be using the variables.

Draft Angle Greater Than 30 degrees
The draft angle is measured relative to the Draft Dir.  If you insert a datum at an angle then use it as the 

direction, you can exceed the 30 degree limitation.

Rename Parts in Assemblies
When renaming a part used in an assembly, have the assembly open and save after the rename.
If the assy isn't open, make sure it is in session (memory).  Open and save before erasing from memory.

Parts & Assemblies in the Search Path
If working with parts that are not in the working directory, set the config.pro search_path

! list of directories to search path 
search_path c:\std\project1 
search_path c:\std\project2 
search_path c:\std\project3 

PreSelection Highlighting
Edit  -->  Select  -->  Preferences,  clear check box

With Highlighting off, you have the option of using a Query Box

System Color Map:



C:\Program Files\proeWildfire 2.0\graphic-library\appearances\appearance.dmt
C:\Program Files\proeWildfire 2.0\graphic-library\appearances\DaveAppearance.dmt

System Colors:
View   ->   Display Settings   ->   System Colors

Scheme
Use Pre-Wildfire Colors

Save Color - Background
View  -->  Display Settings  -->  System Colors
File  -->  Save  (syscol.scl)
{if you save to a different directory, change config.pro setting   system_color_file}

Black Edges (gray part)
View   ->   Color & Appearance

Select "Black" color ball
Assignment - Part

Apply
Clear

Close

Black Edges (colored part)
View   ->   Color & Appearance

Select "Black" color ball
Assignment - Part

Apply
Assignment - Surfaces

Select surfaces
OK (pop-up box)

Pick Color Ball
Apply
Close

View, Display Settings, Model Display... Shade Tab, select "With Edges" box.

Step 1 : Checking the option "With Edges" by clicking #View #Display Settings #Model Display and in the Model display dialog 
box #Shade, the edge color will be the same as the model color. 

Step 2 : Assign a designated color to the solid surfaces of the model by clicking #View; #Color and Appearances; Select a 
different color other than the model color; #Surfaces in the Assignment type; Select a surface #Hold the RMB; #Solid Surfaces; 
#Ok; #Apply. The color of the edges will be same as the original model color. The model color will be the new color assigned. 

Clear Surface Colors
View   ->   Color & Appearance

Assignment - All Surfaces
Clear

Close

UnHide ALL
View  ->  UnHide all

Define Views
View  ->  View Manager

Orient Tab
RMB (right mouse button) NEW

Enter name for new view
RMB Redefine

Note: Datum planes are yellow for the front, brown for the rear
Select and define 2 datum planes for Front, Top, Right, etc as desired
[OK]

[Close]



Define Cross Section View
View  -->  View Manager,  Xsec, New, Enter,  XSec Create

Planar  -->  Single  -->  Done

Display Cross Section
View  -->  Manager,  Names

Display  -->  Visibility

ASSY VIEWS
FRONT = Front/Zo, Top/Yo
RIGHT = Front/Xo, Top/Yo
LEFT = Back/Xo, Top/Yo
TOP = Front/Yo, Bottom/Zo
BACK = Back/Zo, Top/Yo
BOTTOM = Back/Yo, Bottom/Zo

Select Query
Cursor over assembly - RMB - Query - Select from list window

Hidden Datum in Group
Extrude - Pause - Define Datum - Resume

Creates a hidden datum and the extrusion within a group

Adding a CG Coordinate System
1) Insert->Model Datum->Analysis; 
2) Check Model Analysis; 
3) Give it a name in a specified field (press ENTER after) and click Next; 
4) Select Model Mass Properties, click Compute and afterwards, Close; 
5) In a Result params window, click Next; 
6) In a Result datums window, select the datum desired (CSYS or point) and check Yes for each one; 
7) Confirm and the datum is done.

Display Message Log
Info  -->  Session Info  -->  Message Log

Activating a Window Ctrl A

GD&T - Adding a Datum Plane (fundamentals help file)
Create a Datum Plane and name it A, B, or C as required.
Select Datum Plane and RMB -->  Properties,  Change from  [ A ]  to [ - A - ]

GD&T - Adding a GTOL Symbol
Edit  -->  Setup  -->  Geom Tol  -->  Specify Tol

Perp
Model Refs Tab  --  Reference to be selected, Datum, Select Entity (datum B)
Datum Refs Tab  --  Primary  --  pull dn A

[OK],  Done/Return
Done

tol_display
tol_mode
display_tol_by_1000
display_dwg_tol_tags
linear_tol
angular_tol
tolerance_table_dir

---------------------------------------------------------------------------------------------------------------------
ASSEMBLIES



---------------------------------------------------------------------------------------------------------------------
External Reference Control

Tools  -->  Assembly Settings  -->  Reference Control
Edit  -->  Setup  -->  (Part Setup) ↓   Ref Control

Defining Assy Constraints
Placing a small part in a large assy aviod zooming in and out by creating empty constraints
and editing them.  Hit the green "+" (or middle mouse button) to leave the constraint incomplete
and start another.  Once they are defined, you can zoom to another area to add the other
refferences.  You just need to remember which ones to match up.

Exploded-Move Multiple Parts
Preferences --> Move Many

Assembly Relations
Original relations: D4=CWTDBG  Current Relations: D4:1=CWTDBG 
Since this is an assembly relation, the : colon is for the component ID. You could have several 
parts in your assembly that have a d4, for example, this is how you separate them. 

---------------------------------------------------------------------------------------------------------------------
SKETCHER
---------------------------------------------------------------------------------------------------------------------
Turn OFF/ON constraints when inserting a line

Right Mouse Button while in line mode

Line styles 
Sketch-> [  ] Intent Manager (off) -> Geom Tools -> Cosm Font
or
Edit -> Line Style

Ordinate Dimensions
Sketch -> Dimension -> Baseline  (select geom to use as base) MMB
Insert Dimensions by selecting Base Dimension first  (you can select more than one with ctrl)
(NOTE:  Converting Driving dimensions to Ord in a drawing also converts the 3D model dims)

Perimeter of an Arc
An arc can be controlled by dimensioning its length.
1 - Select the arc 
2 - Edit  -->  Convert to  -->  Perimeter
3 - Select dimension that will become a variable dimension
BUG - you can only do this once in a sketch ?

Dimension an Arc Angle
Sketch --> Dimension  -->  xxx  -->  Select one end, the other end, the arc, place the dimension

Ordinate Dimensions
Sketch  -->  Dimension  -->  Baseline

Select geometry to us as a baseline (0.000), MMB to place the dimension.
Sketch  -->  Dimension  -->  Normal

Select the baseline dimension, then select entities to dimension, MMB to place the dimensions.
(More than one can be selected)

---------------------------------------------------------------------------------------------------------------------
CONFIG FILE
---------------------------------------------------------------------------------------------------------------------
Tools  -->  Options

default_dec_places 5
param_dec_places 5
pattern_increment_dec_places 5
show_shaded_edges yes
sketcher_dec_places 5
prompt_on_exit yes



tangent_edge_display dimmed
trail_dir D:\ProE-2.0-Models\Trail_Files
system_hidden_color 60 60 60
display_full_object_path yes
sketcher_lock_modified_dims yes
mapkey vd ~ Select `main_dlg_cur` `MenuBar1`1  `View`;\
mapkey(continued) ~ Select `main_dlg_cur` `View.OrientationCascadeBtn`;\
mapkey(continued) ~ Close `main_dlg_cur` `MenuBar1`;\
mapkey(continued) ~ Close `main_dlg_cur` `View.OrientationCascadeBtn`;\
mapkey(continued) ~ Activate `main_dlg_cur` `psh_view_default`;
mapkey vf ~ Activate `main_dlg_cur` `ProCmdViewNamePick.view`1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1  `FRONT`;
mapkey vb ~ Activate `main_dlg_cur` `ProCmdViewNamePick.view`1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1  `BACK`;
mapkey vt ~ Activate `main_dlg_cur` `ProCmdViewNamePick.view`1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1  `TOP`;
mapkey vl ~ Activate `main_dlg_cur` `ProCmdViewNamePick.view`1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1  `LEFT`;
mapkey vr ~ Activate `main_dlg_cur` `ProCmdViewNamePick.view`1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1  `RIGHT`;
show_axes_for_extr_arcs yes
allow_anatomic_features yes
pro_group_dir D:\ProE\UDF-Library
cmdmgr_trail_output yes

edge_display_quality - very high
model_note_display = no
parenthesize_ref_dim =yes
save_drawing_picture_file =both
mass_property_calculate =automatic (will show on dwg format)
datun_axis_tags =no

display =shade*
display_planes =no
display_plane_tags
display_axes =no
display_axis_tags =no
display_coord_sys =no
display_coord_sys_tags
display_points =no
display_point_tags
spin_center_display
curve_tag_display
spin_with_part_entities =yes

drawing_setup_file directory for drawing options file

================
default_dec_places 5
param_dec_places 5
pattern_increment_dec_places 5
show_shaded_edges yes
sketcher_dec_places 5
prompt_on_exit yes
display shade
tangent_edge_display dimmed
system_hidden_color 60 60 60
display_full_object_path yes
sketcher_lock_modified_dims yes
mapkey vd ~ Select `main_dlg_cur` `MenuBar1`1  `View`;\
mapkey(continued) ~ Select `main_dlg_cur` `View.OrientationCascadeBtn`;\
mapkey(continued) ~ Close `main_dlg_cur` `MenuBar1`;\
mapkey(continued) ~ Close `main_dlg_cur` `View.OrientationCascadeBtn`;\
mapkey(continued) ~ Activate `main_dlg_cur` `psh_view_default`;



mapkey vf ~ Activate `main_dlg_cur` `ProCmdViewNamePick.view`1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1  `FRONT`;
mapkey vb ~ Activate `main_dlg_cur` `ProCmdViewNamePick.view`1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1  `BACK`;
mapkey vt ~ Activate `main_dlg_cur` `ProCmdViewNamePick.view`1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1  `TOP`;
mapkey vl ~ Activate `main_dlg_cur` `ProCmdViewNamePick.view`1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1  `LEFT`;
mapkey vr ~ Activate `main_dlg_cur` `ProCmdViewNamePick.view`1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1  `RIGHT`;
show_axes_for_extr_arcs yes
allow_anatomic_features yes
cmdmgr_trail_output yes
sketcher_refit_after_dim_modify no
hole_diameter_override yes
parenthesize_ref_dim yes
edge_display_quality very_high
prehighlight yes
ecad_comp_csys_def_name ecad_default
ecad_mapping_file D:\ProE\.proi\mimu\BoardTransfer\sk_ecad_hint.map
ecad_area_default_import cosm_area
display_axis_tags no
model_note_display no
save_drawing_picture_file both
mass_property_calculate automatic
system_background_color 0 0 10
display_planes yes
display_axes no
display_coord_sys no
display_points no
pro_group_dir D:\ProE\UDF-Library
pro_material_dir D:\ProE\Materials-Library
pro_note_dir D:\ProE\Notes_Directory
start_model_dir D:\ProE\StartPart
system_colors_file D:\ProE\Colors\syscol.scl
trail_dir D:\ProE\Trail_Files
spin_with_part_entities yes

? maintain_limit_tol_nominal

Shoe/Erase setting 'select to remove' or 'select to keep' defined by   show_preview_default = keep

---------------------------------------------------------------------------------------------------------------------
REFERENCE MATERIALS
---------------------------------------------------------------------------------------------------------------------
There are Wildfire 3.0 books available - just search on www.amazon.com for Pro/ENGINEER - Roger Toogood has written a few, 
plus others - I can't personally vouch for them as I've not seen them. 

There are many other ways to learn Pro/ENGINEER: 
http://www.ptc.com/appserver/mkt/products/home.jsp?k=3303 
http://www.ptc.com/community/resource_center/proengineer/ 
http://www.ptc.com/products/tutorials/index.htm 
http://www.ptc.com/community/express_archive/index.htm 
etc. 
The Knowledge Base is also a fantastic resource - the first place I look if I don't know the answer, and there's excellent suggested 
techniques etc: 
http://www.ptc.com/appserver/cs/search/search.jsp 

Other forums/websites: 
http://www.eng-tips.com/threadminder.cfm?pid=554 
http://www.mcadcentral.com/proe/ 
http://www.proengineertips.com/ 
http://www.cdcweb.co.uk/index.php?page=tutorials_wildfire.php 
http://www.mcaduser.com/ 



http://www.proesite.com/ 
http://www.e-cognition.net/ 
There are other good sites - my apologies to those I've missed. 

In my early days of learning Pro/ENGINEER I read through the help manuals, and I think that's still a great idea: From 
Pro/ENGINEER: 
Help > Help Center > Fundamentals > Pro/ENGINEER Fundamentals 
Also Part Modeling, Assembly Design, etc will certainly improve your understanding.

Cadquest books are really good.
----------------------------

Is there any way to create a hole callout in the draft environment which utilizes the &Screw_Size, &Thread_Depth, etc 
parameters? I know you can make a 3D annotation in the model, but I would like to be able to do it from the draft environment. 
---
>sure, find out the dimension names and use 'em in the note 

I usually use the screw size dimension and add the depth and B.C.and any cbor dimensions and the like in this way: 

(&d) THRU 
{cbor symbol] &D# {depth symbol} &D# 
&D#{degree symbol} APART ON A &D# B.C. 

where &d is the screw size and all the '#' are referenced to whichever dimension ID this particular feature created 
--------------------------------
 ???
Pen Tables
I got all my info. from the help center. I did a global search for table.pnt. This file should be located in your loadpoint for pro-e.
---------------------------------
config.win    file ?  set window layout?
---------------------------------------------------------------------------------------------------------------------
LICENSE SERVER
---------------------------------------------------------------------------------------------------------------------
License Status

Open DOS Window shell Start > Run > cmd
c:
cd \EDS\I-Deas10\sec
lmstat -a -c 7655@az18nt1971.honeywell.com
lmstat -i -c   "

C:\ptc\proiclient3.3\bin\ptcsetup.bat
C:\Program Files\proeWildfire 2.0\bin

Intralink - resetting workspace directory after reinstalling....
RMB the proIntralink desktop icon - Edit - add the following
set pdm_ldb_path=D:\ProE

---------------------------------------------------------------------------------------------------------------------
ProE Help Line
---------------------------------------------------------------------------------------------------------------------
1-800-477-6435 
Service Contract Number 2A112296 (use 2 for A)
Phone sequence to get to mcad help

Mechanical cad support  “1”
ProE “2”
ProE model “1”
ProE drawing “2”

Data Management “2”
Intralink “2”
Intralink “1”
Intralink “2”



---------------------------------------------------------------------------------------------------------------------
Sheet Metal
---------------------------------------------------------------------------------------------------------------------
http://www.me.cmu.edu/academics/courses/NSF_Edu_Proj/Wildfire_short_course/tutorial9.htm

---------------------------------------------------------------------------------------------------------------------
Castings
---------------------------------------------------------------------------------------------------------------------
see help file for Inheritance Features

---------------------------------------------------------------------------------------------------------------------
Misc
---------------------------------------------------------------------------------------------------------------------
Digital Process Design - enables automatic model creation, updating and deployment
without any re-work.  Combined with Horizontal Modeling Techniques simplifies design
changes.  Eliminates downstream problems with reorder, supression and feature deleting
by eliminating interrelated parent/child build steps.

1-Carefully choose references.  This includes references for sketching planes, sketch orientation, sketcher references, 
edges or surfaces for rounds, etc..
  
2-Choose references that follow the design intent.  Though it's easy to make all your features reference only the base 
datum planes, the model won't follow when modifications are made.  Choose references that allow the model "move" with 
the intent as changes are made.
  
(In Practice:  Don't just accept Pro/E's automatic references (especially in Wildfire).  Think about the design intent and 
choose references that are stable and reflect that intent.  Wildfire is horrible about automatic references.  Unless you're 
sketching on a default datum in the assumed orientation, automatic references are rarely applicable or appropriate.  So 
much for minimizing mouse picks.)
  
3-Choose references that won't disappear.  References like edges that disappear when rounded, are not usually the best 
choice.  Datums and planner surfaces are typically better.  References from base features are typically more stable than 
those of later ones.
  
(In Practice:  Pro/E provides different methods of selecting references that give similar results, and some are more stable 
than others.  For example, surface selection by Surf & Bnd, or Loop Surfs when selecting for draft (and other times).  
Select using Intent Chain (May 2002) for edges.  These are just a few examples.  Choose the best method for your 
application.)
  
4-Choose references sparingly.  More references mean more feature interconnectivity which can make the model more 
difficult to work with.  However, choose enough references to make the model follow design intent.
  
(In Practice:  Some models are so tightly tied with references that the model fails with almost any modification.  (August 
2002)  Users wonder why Pro/E is so hard to work with, but in fact, it's the way the model was constructed.  Choices like 
Thru Next have no references.)
  
5-When several features are to reference the same thing (like a planner surface or axis), create datums for control.  (June 
2001)
  
(In Practice:  Key datums (planes, points, axes) are easier to find and select when they are named.  Named features also 
denote significance for someone changing the model later.  Name your important datums.)
  
6-When several aspects of a part must interact (like cuts and protrusions to allow wall thickness and spacing) build control
features like curve sets to manage the interactions, then reference them with the features.
  
7-Create relations that associate features when direct references are not practical.
  
(In Practice:  When writing relations, use comments for "what" and "why".  If other people use the model, they'll be more 
impressed if you are specific in your comments.)
  
8-Drafts and rounds are often best left to the end of the model.  Although this is a good rule, there are times when they 
are required earlier.  Care should be given to where the features are inserted in the model tree.



  
9-Rounds should normally be inserted as round features rather than put in a sketch.  Again, this is a good rule of thumb, 
but there are times where a round can't be created or a dimensioning scheme (design intent) requires the radius in a 
sketch.  As above, carefully consider when.  (The same is true for Drafts, Chamfers, etc.)
  
(In Practice:  It is often good to build models without drafts and rounds, then go back using Insert Mode to put them in -- 
where possible clustering them with the parent features.)
  
10-When the above guidelines don't make sense, carefully consider your options.
  
(In Practice:  Good modeling practices are far more important early in the model than at the end when you're trying to put 
in the last round or draft.

Menu Buttons - Change Default
In a part start a sketch feature and once you are in the sketch environment select Tools>Customize Screen. Under the 
Commands tab select Sketch to add sketcher tools. You can select items on the tool bar and drag them to the locations 
you want. You can also add new menus and flyouts from the New Menu selection at the bottom of the list. Make sure you 
have the check box Automatically save to selected and the file set.


